Platform support for MitID

MitID is intended for all of us to use, therefore the technical requirements to your computer, smartphone, or tablet are few and simple.

If you already are using the internet for news, banking, and shopping, then the same devices are capable of using MitID. However, there are certain exceptions that you can read about below.

For MitID to work on your computer, it requires an operating system and an internet browser that supports the use of MitID.

As of June 1st 2021 the following combinations are supported on computers:

  • Microsoft Windows 8.1 and 10 with latest version of Mozilla Firefox, Google Chrome, Microsoft Internet Explorer 11 or Microsoft Edge internet browser.
  • Apple Mac OS X 10.11, 10.12, 10.13, 10.14 and 10.15 with latest version of Apple Safari, Google Chrome, Mozilla Firefox or in-app (Apple Webkit) internet browser.
  • Apple Mac OS X 11 with latest version of Apple Safari, Google Chrome, Mozilla Firefox or in-app (Apple Webkit) internet browser.

We cannot guarantee that MitID will work with other operating systems or internet browsers than the ones listed.

Read more about the importance of updating software.

JavaScript must be activated in your browser for you to use MitID.

It is not possible to order or log on with MitID, if your browser doesn’t allow cookies.

You can configure your browser to either alert you to approve cookies or to automatically approve or reject cookies.

Read MitID cookie policy.

For MitID to work on your mobile phone or tablet, it requires an operating system and an internet browser that supports the use of MitID.

As of June 1st 2021 the following combinations are supported on mobile phones and tablets:

  • Apple iOS 12, 13 and 14 with latest version of Mobile Safari, Google Chrome, or in-app (SFSafari View Controller) internet browser.
  • Google Android 7, 8, 9, 10 and 11 with latest version of Google Chrome, in-app (Custom tabs) or Samsung Browser 14 internet browser.

We cannot guarantee that MitID will work with other operating systems or internet browsers than the ones listed.

Please note that you can only install the MitID app on devices that can guarantee the level of security required. This means that if your smartphone is jailbroken or rooted, or if you use a beta-version of iOS or Android, you will not be able to install the MitID app.